History of Werks
The software development of Check_MK is organized in so called Werks. A Werk is any change or bug fix that has influence on the user's experience.
Tue, 21 Nov 2017 17:06:30 +0000
Mon, 20 Nov 2017 13:35:16 +0000
5519 ddn_s2a_errors, ddn_s2a_faultsbasic, ddn_s2a_faultsbasic.bootstatus, ddn_s2a_faultsbasic.cachecoh, ddn_s2a_faultsbasic.disks, ddn_s2a_faultsbasic.dualcomm, ddn_s2a_faultsbasic.ethernet, ddn_s2a_faultsbasic.fans, ddn_s2a_faultsbasic.pingfault, ddn_s2a_faultsbasic.ps, ddn_s2a_faultsbasic.temp, ddn_s2a_stats, ddn_s2a_stats.io, ddn_s2a_stats.readhits, ddn_s2a_statsdelay, ddn_s2a_uptime, ddn_s2a_version: Suite of checks to monitor DDN S2A storage devices
These checks use the agent_ddn_s2a datasource program.
Tue, 21 Nov 2017 15:32:46 +0000
Fixed side effect of data source tests: debug mode was left enabled
Tue, 21 Nov 2017 14:48:32 +0000
5520 FIX rstcli, rstcli.pdisks: Fix broken parse function
Some unexpected lines in the corresponding agent section could lead to
neither check nor discovery working (ie crashing). This has been fixed
for all known cases.
Tue, 21 Nov 2017 14:38:43 +0000
Minor wording / output improvements
Tue, 21 Nov 2017 14:28:21 +0000
5535 Check_MK hosts can now use multiple agents
It is now possible to configure multiple Check_MK agents for a single host.
With this change, you can now configure e.g. a ESX VCenter to use the ESX special agent
together with the regular Check_MK agent installed on the monitored host.
All existing hosts remain using their existing configuration after an update. Also
new hosts only use a single Check_MK agent using the already existing logic where
a) The Check_MK agent was contacted via TCP or b) a configured data source program
(special agent or other program invocation) was used.
The new feature can be enabled by changing the host attribute (on hosts or folders)
"Check_MK Agent" to e.g. "Contact Check_MK agent and all datasource programs". This
will make Check_MK use all data sources matching on this host instead of just picking
the first matching one. There is also an alternative option "Use all enabled datasources"
available which can be used to execute only the data sources matching the host.
On the way to this change we have changed server previously existing things:
<li>The host tag group <tt>agent</tt> has been split into multiple tag groups to be
<li>The tag group <tt>ping</tt> and <tt>snmp</tt> have been added and provide the options
which were previously available in the single <tt>agent</tt> attribute.</li>
<li>All these tag groups are treated as <i>builtin</i> tag groups defined by Check_MK
(can not be modified anymore).</li>
<li>Existing configurations of hosts/folders will be translated seamlessly into the new
<li>During updates your site will only apply the changes above in case you have an unmodified
<tt>agent</tt> tag group. In case you have modified it in any way, these changes will not
be applied and you won't be able to use the changes introduced with this werk. You will then
have to clean up your local changes. Once you delete your local tag group "agent", the
builtin one will be used automatically.</li>
<li>The <i>Edit host</i> dialog has split up into more independent sections, the new ones
are <i>Address</i> and <i>Data sources</i> to better visualize the relation of the different
<i>Please note:</i> In case you are using the Web-API calls to create or modify hosts or folders
while setting attributes we changed with this change, you may have to change your API calls.
Tue, 21 Nov 2017 09:42:23 +0000
Fixed several tests after code and functional cleanups
Tue, 21 Nov 2017 08:41:23 +0000
Moved functions to better places
* Now that the data structure is getting clearer the main function
for gathering the data of a host get_host_sections() can be
moved to the DataSources() object.
* Moved get_section_content_for_check() that prepares the section_content
for a check/inventory plugin to MultiHostSections() object.
Mon, 20 Nov 2017 12:13:17 +0000
Fix some naming conventions related to agents/checking
* section_name : The identifier for a section of monitoring data
* check_plugin_name : The identifier for a Check_MK check plugin
* active_check_name : The identifier of a active check plugin
* host_sections : Object managing parsed data received from data sources
* section_content : A list of lists (Agent: list of rows splitted by separators)
Mon, 20 Nov 2017 12:10:22 +0000
Fixed merging sections from cluster nodes for cluster hosts together
Fri, 17 Nov 2017 12:57:56 +0000
Added helpful message when viewing the service discovery page of clusters which have no services
Fri, 17 Nov 2017 12:48:32 +0000
Cleaned up discovery code
* Separated data gathering from doing the discovery
* Performance: Reduced duplicate data gathering on service discovery
page of WATO
* Moved data gathering (including all caching options) to top level
* Moved IP address resolution to top level which makes it much
clearer in which situations IP addresses are set by caller or not
Fri, 17 Nov 2017 11:23:38 +0000
Updated bug entries #3014
Fri, 17 Nov 2017 11:08:47 +0000
Improved logging of cache file writing
Fri, 17 Nov 2017 10:10:34 +0000
Moved persisted info update logic to DataSource()
Fri, 17 Nov 2017 09:57:15 +0000
Updated bug entries #3013
Fri, 17 Nov 2017 09:24:48 +0000
5436 FIX Fixed logical problem with SNMP check interval rule
The rule was previously configured for each individual check. This was not really
correct, because the SNMP data is fetched for main checks and their sub checks
together. This means that you can not define inidividual SNMP checks intervals for
The ruleset "Check intervals for SNMP checks" has now been changed to work with the
"section names" instead of inidividual checks.
Thu, 16 Nov 2017 12:15:14 +0000
Minor output cleanups
Thu, 16 Nov 2017 11:22:57 +0000
Fixed handling of edge case on service discovery page with snmp check interval configured
Thu, 16 Nov 2017 08:02:57 +0000
Cleanup cache handling of data sources
* Removed modification of configuration options
* Refactored cache read function
* Improved verbose logging of cache usage decisions
* Use better names for cache influencing attributes